GoToMyPC Service Unavailable
Incident Report for Pro/Central, GoToMyPC, Hamachi
Resolved
All services have been restored. We apologise for any inconvenience.
Posted 8 months ago. Mar 19, 2018 - 14:31 UTC
Monitoring
Services have been restored. We are keeping a close eye on the situation and working to identify the cause for the issue.

We appreciate your patience regarding this matter.
Posted 8 months ago. Mar 19, 2018 - 14:11 UTC
Investigating
We are aware that some users are unable to log in to GoToMyPC.
Posted 8 months ago. Mar 19, 2018 - 14:01 UTC
This incident affected: GoToMyPC.