LogMeIn Pro/Central - New customers unable to receive verification emails
Incident Report for Pro/Central, GoToMyPC, Hamachi
Resolved
Our engineers have investigated this concern and have confirmed this to be a user-side issue. The service is fully operational and all LogMeIn Pro/Central emails are being received correctly as long as a correct password has been entered.
Posted 3 months ago. May 30, 2019 - 20:39 UTC
Update
Update: Account verification emails when you sign up for a new account & sign-in from new location verification emails are affected.
Posted 3 months ago. May 30, 2019 - 20:14 UTC
Investigating
We are actively investigating reports that some LogMeIn Pro/Central customers may be experiencing issues receiving new IP verification emails.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted 3 months ago. May 30, 2019 - 20:13 UTC
This incident affected: Pro/Central.