We have confirmed that the issue has been resolved and that all systems are 100% operational.
We will conduct an internal review of this issue and make appropriate improvements to our system to help prevent or minimize future recurrence.
Posted Sep 28, 2023 - 20:43 UTC
Monitoring
Our underlying third-party peer provider has been advised by their vendor that they are observing expected network behavior and we are also seeing improvements.
We will continue monitoring the situation and provide a final update shortly.
Posted Sep 28, 2023 - 20:24 UTC
Identified
Our engineers have identified the issue as being caused by an industry-wide incident affecting multiple upstream providers.
We will provide another update as soon as they become available.
Posted Sep 28, 2023 - 20:00 UTC
Investigating
We are actively investigating reports that some GoToMyPC and LogMeIng Pro & Central customers may be experiencing issues with outbound MFA SMS not being delivered or having delay.
Our engineers are working to identify the issue and will provide another update shortly.