GoToMyPC - Connectivity issues
Incident Report for GoTo
Resolved
We have confirmed that the issue has been resolved and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our system to help prevent or minimize future recurrence.
Posted Jul 09, 2024 - 16:51 UTC
Identified
A subset of GoToMyPC users are experiencing connectivity issues when trying to access remote host machines. Our engineers have confirmed that the issue is a result of a network connectivity problem with the upstream ISP vendor, likely due to the ongoing tropical hurricane situation in the region.

We are actively monitoring the situation in the region and will provide updates as and when it is available.
Posted Jul 09, 2024 - 05:42 UTC
This incident affected: GoToMyPC.