G2P - Unable to create trial accounts
Incident Report for Pro/Central, GoToMyPC, Hamachi
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted about 1 month ago. Sep 10, 2019 - 10:35 UTC
Investigating
We are actively investigating reports that all GoToMyPC customers may be experiencing issues while creating a trial account

Our engineers are working to resolve the issue and will provide another update shortly.
Posted about 1 month ago. Sep 09, 2019 - 15:25 UTC
This incident affected: GoToMyPC.